Knowledge Base

Search Knowledge Base

KB #240096: Column Encryption Manager Fails to Load

Type:

Fix

Summary:

When running Column Encryption (NLCOL_E.EXE), it fails to load, or gives a message to install the SQL 2005 Backwards Compatibilty Pack.

Additional Information:

Column Encryption requires SQL-DMO which is not supported by default in SQL 2005 and later. You must install the SQL 2005 Backwards Compatibility Pack which includes support for SQL-DMO.

There are available from the Microsoft site:

It is necessary only to install the component labeled:
“SQL Distributed Management Objects (SQL-DMO)”
You do not need to install the other components in the installer. Column Encryption requires DotNet 4 or later

You may download DotNet 4 from Microsoft’s download page.

Top